Welcome to Schneider / Amstrad CPC Forum. Please login or sign up.

21. April 2024, 22:22:56

Login with username, password and session length

Shoutbox

TFM

2024-04-08, 20:42:44
Happy Sonnenfinsternis!  :)

TFM

2024-01-15, 17:06:57
Momentan billige Farbbänder auf Ebay für PCW

Devilmarkus

2023-07-09, 10:37:40
Zweiter 👋😂🤣

TFM

2023-06-13, 14:21:49
Sommerloch!

TFM

2023-05-30, 17:00:20
Erster ;-)

Recent

Members
Stats
  • Total Posts: 11,698
  • Total Topics: 1,338
  • Online today: 110
  • Online ever: 1,724
  • (16. January 2020, 00:18:45)
Users Online
Users: 3
Guests: 77
Total: 80

77 Guests, 3 Users
TFM, Gauntlet, Dobbertin

Disckit beenden, oder weiter formatieren/ kopieren funktioniert nicht

Started by heiko, 14. November 2022, 07:37:13

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

heiko

Hallo,
wenn ich disckit benutze und damit einen Vorgang beendet habe, kommt die Meldung "Press any Key ..."
Laut Handbus sollte man dann nach Drücken einer Taste wieder ins Menü kommen. Das passiert aber bei mir nicht, es kommt stattdessen immer nur die Meldung "Press any Key..."
Das passiert sowohl bei disckit2 , als auch bei disckit3
Ich habe mehrere Systemdisketten ausprobiert und immer mit dem gleichen Ergebnis.
Ist das nun ein Anwenderfehler? Wenn ja, was mache ich falsch?
Gruß
Heiko

HAL6128

Es dürfen dabei keine Disketten in den Laufwerk mehr vorhanden sein, damit das Programm zurück ins Menü springt!

Es könnte auch sein, dass je nach Umgebung (z.B. ein Erweiterungsrom oder andere Software Disckit stört).

heiko

Die Disketten sind draußen, der CPC ist ohne Erweiterungen.

xesrjb


HAL6128

Erzähl mehr über Deinen CPC Aufbau. Woher stammen zudem die Disketten? Ich hatte tatsächlich das gleiche Problem bei einigen DSK Images aus dem Internet.

heiko

Hallo,
Quote from: HAL6128 on 14. November 2022, 21:24:37
Erzähl mehr über Deinen CPC Aufbau. Woher stammen zudem die Disketten? Ich hatte tatsächlich das gleiche Problem bei einigen DSK Images aus dem Internet.
es handelt sich um einen unveränderten 6128, mit einem weiteren FDD angeschlossen. Alles über die originalen Kabel. Beide Laufwerke funktionieren ansonsten prima. Ich habe es mit verschiedenen Disketten ausprobiert, die nach dem Formatieren und bespielen auch wunderbar laufen.
Das Formatieren, Kopieren und Verifizieren von Disketten funktioniert auch bestens, nur dass sich DISCKIT aufhängt und ich nach jedem Vorgang CPM neu starten muss ist schon nervig
Gruß
Heiko

xesrjb

Dann geben die Laufwerke kein Ready ab. Das interne müsste es eigentlich  :gruebel:

Was ist dein |B Laufwerk?

xesrjb

heiko

Hallo
Laufwerk B ist ein FDD. Ich habe aber noch ein zweites, mit dem werde ich es mal noch probieren.  Auf jeden Fall ist das ja schon mal eine Richtung für die Fehlersuche. Ich werde auch mal versuchen wie es mit abgeklemmtem Laufwerk B ist, dann müsste sich ja zeigen, welches Laufwerk der Verursacher ist.

Gruß
Heiko

TFM

Mit FDD meinst Du wahrscheinlich ein FD-1 3" Laufwerk von Schneider / Amstrad.

Ja, auf Anhieb würde ich auch sagen, dass es hier ein Problem mit dem Ready Signal gibt. Ohne Diskette darf das Laufwerk nicht Ready melden.

Wurde am CPC6128 bzw. den Laufwerken etwas verändert?
TFM of FutureSoft
http://www.futureos.de --> Das Betriebssystem FutureOS (Update: 20.12.2023)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> RSX ROM für LambdaSpeak (Update: 26.12.2021)

xesrjb

Quote from: TFM on 17. November 2022, 14:35:06
Mit FDD meinst Du wahrscheinlich ein FD-1 3" Laufwerk von Schneider / Amstrad.

Ja, auf Anhieb würde ich auch sagen, dass es hier ein Problem mit dem Ready Signal gibt. Ohne Diskette darf das Laufwerk nicht Ready melden.

Wurde am CPC6128 bzw. den Laufwerken etwas verändert?

Das ist immer ein Ready Problem..., entweder falsches/defektes Kabel oder das Laufwerk ist verändert.

Probiere bitte mal Disckit ohne angestecktes 2. Laufwerk, ob der Fehler auch da...

xesrjb

heiko

Hallo,
ich hatte heute erst wieder Zeit mich mit der Sache zu beschäftigen.
Ohne angestecktes Laufwerk, also nur mit dem eingebauten Laufwerk funktioniert es wunderbar. Also liegt der Fehler im angeschlossenen Laufwerk (FD-1)
Die Frage ist jetzt nur, wie ich dem Fehler auf die Schliche kommen kann, um ihn zu beheben. Wie ist das denn technisch mit dem Signal gelöst?
Gruß
Heiko

xesrjb

1. Mache bitte detaillierte Fotos vom Kabel von den Stellen wo die Stecker angequetscht sind.
2. Mache bitte vorsichtig beide Stecker auf und schaue, ob alle Pinne vorhanden sind oder vielleicht Adern im Stecker nicht verbunden sind. Also auch bitte Fotos von den geöffneten Steckern...

xesrjb

heiko

Hallo,
ich werde morgen Fotos machen und auch mal mit einem anderen Kabel testen.
Gruß
Heiko

heiko

Hallo,
ich habe heute mal ein anderes Kabel ausprobiert, mit dem gleichen Ergebnis. Beide Kabel sind identisch.
Ich habe zwar auch noch ein zweites Laufwerk, das erkennt aber den Schreibschutz nicht (andere Baustelle).
Bilder vom Kabel hänge ich an. Wie man den Stecker öffnet, konnte ich aber nicht herausfinden.
Könnte es an den Jumpern liegen?

Gruß
Heiko

xesrjb

So sehen meine Kabel aus...

xesrjb

und das mit dem Schreibschutz liegt am fehlenden Pin...